Using Dynamic IP with HE Tunnel and DynDns

At my home I am using both a Huricane Electric IPv6 Tunnel and DynDNS with my dynamic PPPoE DSL.  While static addresses are available, the additional price isn’t worthwhile for my current uses.  I found that Hunicane Electric now has a dynamic interfaces that works similar to DynDNS.  I was able to get the following configs to set up DynDNS and a dynamic HE Tunnel.

ip ddns update method DynDNS
 HTTP
  add http://USERNAME:PASSWORD4@<s>/nic/update?system=dyndns&hostname=DNSNAME&myip=<a>
 interval maximum 10 0 0 0
!
ip ddns update method Tunnel
 HTTP
  add http://ipv4.tunnelbroker.net/ipv4_end.php?ipv4b=AUTO&pass=PASSWORD&user_id=USERID&tunnel_id=TUNNEL-NUM
 interval maximum 10 0 0 0
!
!
interface Tunnel0
 description Hurricane Electric IPv6 Tunnel Broker
 no ip address
 ipv6 address 2001:DB8::2/64
 ipv6 enable
 tunnel source Dialer0
 tunnel destination HE-ENDPOINT
 tunnel mode ipv6ip
!
!
interface Dialer0
 ip ddns update hostname HOSTNAME
 ip ddns update DynDNS host members.dyndns.org
 ip ddns update Tunnel
 ip address negotiated
 ip mtu 1492
 ip nat outside
 encapsulation ppp
 ip tcp adjust-mss 1460
 load-interval 30
 dialer pool 1
 dialer-group 1
 ppp authentication XXXXXXXXXXXX
 ppp chap hostname XXXXXXXXXXXX
 ppp chap password XXXXXXXXXXXX
!

Leave a Reply

Your email address will not be published.